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General Questions

What is iRidium for?

iRidium is a software product for professional integrators of automation and Audio/Video systems.
With the help of iRidium you can create a panel for controlling all your equipment from any iPad,
iPhone, Mac, Android or Windows based device. The software supports many popular automation
systems and allows you to create your own drivers. The important iRidium feature is creation of fully
customizable user interfaces which combine control of all systems.

I am not an integrator. Can I use iRidium?

If you have a Smart Home, the Multiroom system, Home Theater, etc., you can contact your
integrator and request iRidium-based remote control from them.

Is iRidium a software solution?

Yes, it is. You do not need any server or hardware to work with iRidium. You just install the software
package on your PC and create a visualization project. The client application installed on your iOS,
Android, Windows or Mac will enable launch of your visualization project on any supported OS. The
client application connects to the controlled equipment directly, without any intermediaries
(excluding your router providing Wi-Fi connection or communication with your equipment via
Ethernet). You do not need to have a web-server or PC to work with iRidium. Internet connection is
not required.

Where can I download the software components from?

The iRidium components are available for downloading in the Downloads section of the iRidium
mobile web site.

#Prices.2C_Licenses.2C_Registration
#Prices.2C_Licenses.2C_Registration
#Prices.2C_Licenses.2C_Registration
#Visualization_Capabilities.2C_GUI_Editor
#Visualization_Capabilities.2C_GUI_Editor
#Visualization_Capabilities.2C_GUI_Editor
#Equipment.2C_Drivers
#Equipment.2C_Drivers
#Equipment.2C_Drivers
#i2_Control.2C_Supported_OS
#i2_Control.2C_Supported_OS
#i2_Control.2C_Supported_OS
https://iridiummobile.zendesk.com/hc/en-gb
http://www.iridiummobile.net/download/software/


What are requirements to PC where iRidium will be running on?

You can find information about requirements to PC and control panels in the corresponding section
of Wiki.

Where should I start

Decide what equipment you want to control with iRidium. Install the software components and learn
instructions about iRidium for your equipment. Video-lessons and on-line webinars if they are
already available for your equipment will help you to speed up the process. While creating the
project refer to the information about iRidium components and licensing.

Do applications for PC work on Windows only?

Yes, they do. The setup for PC can be installed only on Windows 7/8 OS (or launch with the help of a
virtual machine, Windows Emulator). Do not activate iRidium licenses for virtual machines: they
generate new HWID at each launch and your licenses will not work.

↑ Back

Prices, Licenses, Registration

How to activate a license”?

Activation means creation of the license file (<name>.irl) with the help of the activation key. You
receive the payed key which you will assign to the control panel (until the key is not assigned the
control device is not defined). This procedure is performed in the MY ACCOUNT section of the web
site. All keys should be added in the MY ACCOUNT section and then assigned to particular devices
with the help of HWID/Serial Number. The ready license file should be added in Transfer and
uploaded to the control panel together with the visualization project. You can find more detailed
information about the activation procedure here.

How to get HWID?

To get HWID, please see: HWID, Serial number. This identifier is used at activation of iRidium
licenses.

How much is iRidium?

All iRidium components are free. Only licenses are sold. Without licenses there won’t be connection
with the controlled equipment.
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License prices can be accessed only by the companies engaged in the Automation market. You can
see them after you go through Full Registration on the iRidium mobile web site (for integrators).
Consumer prices can be requested from an iRidium distributor in your country.
Sample GUIs (templates of graphic interfaces) and JS modules (projects and drivers for working with
various equipment which is not included in the standard iRidium base) are additional but not
compulsory for use materials. Sample GUIs and JS modules are sold or distributed for free.

Where can I see license prices for an integrator?

You can find information about prices in the "BUY" section of the iRidium mobile web site. You can
see the price-list and buy iRidium licenses by the prices for integrators only if you belong to the
company working on the Automation market. You can confirm the status of your company after
going through Full Registration on the web site (available after the initial registration).

Is a license for each control panel or it can be used for several devices?

It depends on the license type. There are two main types:
Device License - you have to get new license for each iRdium product. It is a license for a control
panel. You need to get a Device license for each control panel. The license will work only on the
panel which was selected initially (at the license activation).
Site License - it can be used for iRidium products for AMX, Crestron, KNX, KNX IP BAOS, HDL,
Global Cache, Helvar. It is a license for a controller. You can upload the license file of this type on
any number of control panels. All of them can be connected to the controller selected at the license
activation.
You can find detailed information about the licensing system here.

Is the downloaded GUI Editor fully functional for creating projects or I need to have a
license for it too?

The license is not required for working with GUI Editor. All functions of GUI Editor for creating
projects are available but it is recommended to license Emulator of GUI Editor.
Emulator is a program built in GUI Editor. It allows you to see how your project will work on the
customer control panel. Only the graphic part of the project can work without the license. The driver
part of the project and feedback form scripts are not functional.
On the first stage of working with iRidium it is convenient to use free Trial licenses provided for
each registered user.

Do licenses have a validity period?

Only free Trial licenses have a validity period (30 days).

Where can I take Serial Number of my АМХ (Crestron, BAOS) controller?
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You can find information about receiving identifiers in the corresponding section of Wiki: HWID,
UDID, Serial Number.

Can I use several Site licenses on one panel?

Only one Site license for one controller can be uploaded on one control panel. But the Multi-design
function available starting with iRidium v.2.1 enables upload of several projects on one control
panel. For each of the project there is its Site license.

Can I merge two Site or Device licenses?

You cannot merge Site licenses. But you can do it with Device licenses. You cannot merge Site and
Device licenses. To merge two Device licenses for different drivers you should activate two license
activation keys indicating the same HWID. Download the second activated license file on your PC. It
will contain two drivers licensed with the help of two different keys.

I bought a Device license for KNX. Can I use it to control Modbus too?

No, you can't. Buying a license for one of iRidium products you can control only the driver you
indicated in licnese (in this case - KNX). All other drivers cannot be controlled with the same license.
Device Full license includes all iRidium drivers.

Are there any limits for the number of equipment controlled with the help of one iRidium
license?

No, there aren't. The number of the controlled equipment and addresses is not limited.

Can I upload the project on my iOS or Android device without a license?

Yes, you can. But there won't be any communication with equipment: you will not be able to send
commands to controllers and receive feedback. The other functions (graphics, navigation, interface
scripts) will work.

How can I update licenses when switching from V2.1 to V2.2?

You don't need to update the licenses. They are fully compatible. HWIDs of control panels stay the
same.

How can I update licenses when switching from V1.5 to V2.x?

You don't need to update the licenses. You will be able to use V1.5 licenses when working with V2.x.
But V2.x licenses cannot be used when working with V1.5. In V2.1 identifiers of all iOS devices
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(iPhone, iPad, iPod touch) changed. It will affect upload of new projects on iOS panels. See more
information here.

What is Full registration on the web site for?

After going through Full registration you will be able to buy iRidium products - licenses and sample
GUIs - directly on the web site by dealer prices.

How can I pay for licenses?

Licenses can be received in two ways: via the iRidium Mobile web site or by invoice. If there is an
iRidium distributor in your country refer for the invoice to them. For the payment via the web site go
through Full registration.

What documents are provided with license key?

When paying with the credit card the documents are provided by our partner - Avangate payment
system (http://www.avangate.com). If it is a wire transfer we provide a license agreement, delivery-
acceptance act and an invoice.

What is the period you provide license activation keys in?

When the payment is made from the credit card the keys are sent within 24 hours. If it is a wire
transfer, the keys are sent when the payment is received on the iRidium mobile account.

My Full registration was disapproved (not enough information, etc.) What should I do?

iRidium distributors confirm the integrator status of your company. Contact an iRidium distributor in
your country to clarify the situation and confirm the company status. Do not start the registration
procedure if you don't have enough data for it. The forms which are not fully filled are disapproved
and you can waste a few days.

I cannot activate my key. I receive the error "wrong ID" (This code is wrong!)

This error shows that you indicated the wrong unique panel identifier (HWID) or Serial Number of
the controller you activate the license for. Please see information about license activation and
information about receiving identifiers one more time.

Every time I start Transfer I receive a new HWID of my PC. What should I do?

HWID is a unique device identifier. It should not change. Otherwise your license will not work. If you
have such a problem there can be several explanations:
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a) you work on a virtual machine (Windows Emulator). Switch to the regular Windows based PC.

b) you have hard disk RAID-array used on your PC. Deactivate it.

↑ Back

Visualization Capabilities, GUI Editor

Updating iRidium components

To update all iRidium components go to iRidium GUI Editor, open the menu Tools > Options > File
Operating, mark the field "Check Updatings at start". Then restart GUI Editor and agree to install
the new version. After the download and unpacking are finished updated GUI Editor will
automatically open on your PC.

"Big" updates (when the app version changes, for example, 2.1 > 2.2) has to be performed using the
full setup which can be downloaded from the web site.

Updating iRidium components to Beta-version

iRidium Beta-versions are meant for testing new capabilities of the software package but they are
not stable. If you use Beta-versions you should be confident in you actions and save backup copies of
your projects. To update all iRidium components to Beta-version go to iRidium GUI Editor, open the
menu Tools > Options > File Operating, mark the fields "Check Updatings at start" and "Check Beta-
builds". Then restart GUI Editor and agree to install the new version. After the download and
unpacking are finished updated GUI Editor will automatically open on your PC.

How can I add a license to Emulator?

Open GUI Editor, go to the menu Tools > Options > Emulator - here you can see the field where it is
necessary to indicate the path to the license file for your PC. The license is stored in the *.irl format.
You can receive it in the MY ACCOUNT section on the iRidium mobile web site. Users registered on
the web site receive two free Trial licenses.

Emulator in iRidium GUI Editor does not control the set up equipment.

Check that you added a license for Emulator in Tools > Options > License Path. More >>

GUI Editor works slowly and consumes a lot of memory.

Check that you use the DirectX render in Tools > Options > Showing.  More >>

iRidium GUI Editor doesn’t start and shows the message "List index out of bounds (1)"

Go to the register (Execute > regedit) and delete HKEY_CURRENT_USER\Software\iRidium mobile
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Ltd.\iRidium\2\GUI

At project emulation all fonts and (or)images in the interface got missing

It is possible that you renamed or relocated the initial project file. When trying to save such file, the
fonts could be damaged. In this case you need to open the *.irpz project as a ZIP archive and delete
the Fonts folder from there. At the next launch everything will work fine.

At the launch of GUI Editor I receive the message that MSVCRP100.dll is missing and
Editor does not launch. What can I do to fix that?

Install Update packet 1 for Microsoft Visual C++ 2010 (x86) on your PC or download the last set up
from the web site.

Will a project created in V2.1 work in V2.2?

Yes, it will. These iRidium versions are fully compatible. Before uploading the interface, save it in the
new editor version (it is recommended to save the project under a new name to preserve the
compatibility of the initial project with V2.1)

Will a project created in V1.5 work in V2.x?

V1.5 projects can be converted for V2.x but there are limitations. Some drivers cannot be imported
from old projects to new ones. Some relations of items and commands have to be restored manually.
See more information here.

How can I download data from GC Cloud to work offline?

Download of the Global Cache data base is not possible. It is an on-line tool.

Transfering drivers (devices) from one project to another

If you created a device with a set of commands and feedback channels in one project and want to
transfer it to another project you can use the special import function. It is available in the GUI Editor
menu File > Import. Go to the import menu, select the project file in the irpz format (or another
available format) where you want to transfer the tree of devices from and confirm the import. As a
result you will receive the list of drivers of the imported project. Mark the ones you want to transfer
to the new project. Press ОК. New drivers will be added without substituting the drivers in the new
project.

Merging several pojects

If it is necessary to merge two projects or add a script module you can use the special merge
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function. It enables transfer of all pages, drivers and scripts of one project to another saving
relations between commands and items. Items of the merged projects do not overlay and substitute
each other. To enable the merge make sure there are no pages, drivers, script modules with same
names (rename them). When merging projects with different resolutions the size of the subsidiary
project will be changed to the size of the main one. See the video >>

Change the resolution of the project and all its items

A ready project (for example, for iPad) can be resized for another device (if automatic resize of the
project on the panel does not work for you). You can do it by changing the resolution in the settings
of the ready project. Project > Project Properties > project size.

Fast text editing on items

Use hot keys (not to select the text editing field manually):
F2 - edit the text in State 1 of the item,
Shift+F2 - edit the text in All States of the item.

The text written in the item is not displayed

Check that it is written in the required item state (State) and its color is not transparent (see Text
Color > the slider on the right: 255)

Animated items in Gallery

Items with more than two states are considered animated. They can play frame animation activated
by different events in the system. Such items can be created from separate frames and added in
Gallery of GUI Editor combining all frames in one object. See more information here.

Import of images in Gallery

You can add your images in the project by dragging them in Editor Workspace (on the project page)
from any folder. Import of images to Gallery is available in the right-click menu in Gallery (Import
File, Import Folder). See more information here.

Chameleon buttons with dynamically changing color

There are Buttons with two states in standard iRidium Gallery (folder iRidium > Buttons). All of
them are blue by default. But it's not their constant value. The color can be changed depending on
the project style. It can be done with the help of Chameleon Image - and image with changeable
color. The color of Button with Chameleon Image will correspond to the color selected for the Button
border or filling. Thus, by changing the color of the Button border you change the color of
Chameleon Image. See more information here.
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Time, date, battery charge and other data for projects

System properties of your PC or tablet computer with running iRidium can be displayed in the
visualization project. There are special variable for that - System Tokens. They can be accessed via
the Project Device Panel tab in GUI Editor. System Tokens are available for reading only (but some
of them, for example screen brightness, can be changed). If you add them as feedback channels on
project items you will be able to display the current time, date, network status, GPS and many other
properties. See more information: description of system tokens and System Tokens API.

Radio Buttons

It is a set of graphic items which allows the user to choose only one of the preset range of options.
Switchers of this type are joined in groups of two or more items. There is no any separate graphic
item type for creating Radio Buttons. They are synchronized with each other via the common project
variable - Project Token which stores the current state if the group and sends it to each item of the
group. You can see the example of creating Radio Buttons for creating the project menu here.

Vertical/horizontal design

iRidium projects can contain pages with different orientation which are "alternative" to each other.
The selection of which page to show is made by the client application and depends on the position of
the control panel. When you turn the control panel, the project also turns. See information about
setting up pages with different orientation here.

When scrolling Static List, buttons on it are clicked

Use the Release event instead of Press. Try not to use Trigger Buttons.

Screensaver

It is any project page which will automatically open if the user doesn't do anything with the project
for some time. It is activated in the project settings. See more information here.

Hyperlinks (URL), mailto, tel, sms, ...

URL (Universal Resource Locator) is a universal indicator of the resource which is used for ativating
some application, service or some other action on the control panel. URL are different for different
OS. They are used differently on iOS/Windows/Android/OS X. The most popular way of using URL-
schemes is opening hyperlinks in the window of the standard browser. See information about using
URL-schemes on different OS here.

Auto removal of unused images from projects
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Sometimes you add images and icons to the project and never use them again or resize them. These
objects do not function but they are stored in the project increasing the size of the project and time
of project uploading. To remove these objects fast use  the special optimization tool.

"Mutex" popups (Popup Group)

If you can select a group of popups in your project which can never be shown together such popups
can be considered mutex. they can be placed in Popup Group for convenience, It allows you to open
only one of the popups in the group at a time and closes all the previous one automatically. Popup
Group is available in the Projects Overview window. See more information here.

When I open a popup the other one closes by itself

This is how Popup Groups work in the alternative tree of pages. More >>

Create an item with equal sides

If you press on the Ctrl key when using the Draw Item tool the item created in Workspace will be
square and not rectangular with random sides. The size of the square is defined by the cursor.

Display all interface items in the Pages tree

If you want to display all graphic item of the project and not only pages and popups in Projects
Overview, mark the Show Items In Tree field in the tab Tools > Options > Showing.

Grid in Editor Workspace

To position project items in the grid with the preset step activate it in Editor Toolbox, the Grid
button.

Add objects (pages, popups) to Gallery together with script files

If you created a script module assigned to a particular project popup or page (for example, the one
displaying the weather or currency exchange rate), you can save the module with the page to
Gallery. In order to do that open Gallery, select the page, press on the Alt key and drag the page
from the Project Overview window to Gallery. You will see the dialog window for selecting the script
file which you should save with the page. You can use such an object in your project.

IP cameras, stream video

iRidium supports processing of stream video in the H.264, MJPG formats. Such stream can be output
on any graphic item of the interface similarly to a standard image. See information about setting up
video in iRidium here.

I cannot find the link to the stream from my IP camera (DVR)
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Useopen resources. More >>

What IP cameras work with iRidium?

The important feature of IP cameras when working with iRidium is the possibility of receiving the
direct link to the stream video in the MJPG or H.264 formats. For example, the following cameras
have been tested (not all of the models, see camera specifications!): Axis, D-Link, Panasonic, Vivotec
, etc. See more information here.
Do not choose cameras working via ActiveX, which requires installing the driver on PC. You cannot
receive the link to the video from such cameras.
Here is the useful resource where you can see the list of camera manufactures and types of video
stream you can receive from cameras: ispyconnect.com.
iRidium mobile is not responsible for your choice of IP cameras (recorder) and does not guarantee
compatibility with particular models which haven't been tested by the company. The choice is made
at your own risk.

Can I set up control of PTZ IP cameras (their turning and focus)?

Control of position and focus offset of IP cameras is made with the help of the PTZ (pan-tilt-zoom)
commands. Usually regular GET-requests sent by the HТТР protocol are used. Thus to implement
PTZ control for an IP camera in iRidium you need the AV & Custom Systems (НТТР) river which
enables setting up of these commands in the project. You will require the license for AV & Custom
Systems.

SIP - integration with Intercom, Video Intercom, calls between iRidium panels

Beginning with V2.1 iRidium supports the SIP protocol for setting up voice communication between
iRidium panels, other SIP-clients, other iRidium panels.

iRidium panels work in the SIP-client mode. In order to have connection with Intercom you need to
have the set up SIP server. You need to indicate the connection properties in the settings of iRidium
SIP-client. iRidium provides only the client part, the server part is selected to the discretion of the
integrator. The SIP driver for iRidium V2.1 can be downloaded for free from the iRidium mobile web
site.

Do notifications for iOS work when the application is minimized?

No, they don’t. Notifications can be received only when the application is opened on your control
panel.

What is an *.irgl object?

.irgl is an object of iRidium Gallery stored in the directory C:\Program Files (x86)\iRidium
mobile2\Editor\Gallery. Such objects are not meant for adding to GUI Editor directly. If you need to
add them in your Gallery just copy the folder in the indicated directory.

http://www.ispyconnect.com/sources.aspx
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Limiting access to project pages (hosts/children/engineer/etc.)

To limit access to some interface pages use the system of passwords. There are 4 levels of passwords
you can give to different categories of users. See more information here.

How to download the project back to my PC?

At the moment the download of projects from control panels to PC is not possible. Save initial copies
of your projects on secure carriers and on-line resources.

Can I open a hyper link or show a page in iRidium like in the web browser?

No, you can’t. At the moment iRidium does not support the browser function. You can open hyper
links in the standard browser of your control panel.

↑ Back

Equipment, Drivers

Emulator in iRidium GUI Editor does not control the set up equipment.

Check that you added a license for Emulator in Tools > Options > License Path. More >>

How do built-in drivers drivers differ from the script ones?

Built-in (native) drivers are included in the standard iRidium base. Such drivers are quickly set up in
GUI Editor. They are standardized and are provided with detailed instructions and examples. Script
drivers are always created on the base of the native AV & Custom Systems driver with the help of
iRidium scripts (the programming language based on Java Script). They are used for controlling any
systems which are not included int he standard iRidium base. Usually the script drivers are
distributed with the visualization project (for example, XBMC, Sonos, iTunes, ... ).

How can I change the IP-address of the controlled system in real time?

It is not possible to set up two IP-addresses for on driver in the project for switching between the
local network and the Internet. But you can change the IP-address of connection to the controller
while working with the project. In order to do that use the simple script (IR.SetParameters), which
changes connection properties for the driver while it is working. See more information in the
instructions for your equipment.

Can several drivers work in one project?

Yes, they can. Drivers in iRidium projects work independently from each other. That is why you can
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add as many drivers as you need in one project.

Does a project, for example the one for KNX or Crestron communicate with equipment
directly? Or does iRidium need an installed server (iRidium Gate)?

The iRidium Gate application is NOT required for using. The client communicates with the
equipment directly. But there are cases when iRidium Gate expands control capabilities, makes
available work via the Internet, enables connection of several clients to the controller. See more
information in instructions for working with iRidium Gate and different systems.

I need to send HTTPS requests (not HTTP) to the AV & Custom System driver. Are there
any special terms for these commands in iRidium??

At the moment HTTPS works only on Windows. If a certificate is not valid, it won’t work. If a
certificate is standard or manually-generated, then it will work. To activate HTPPS you need to
indicate Enable in the SSL property of the AV & Custom System HTTP driver.

The command from the Move event is sent too often

Add a delay before the command: Delay(100) ms and the command will be sent once in 100 ms. You
can set up another delay time. More >>

The value on the button is displayed as 0.00000, but I need it to be 0.0

Change the "In Text" tag of the graphic item to In Value. In the text field of the item write $V, $F1 or
another template. More >>

I assign a command to the button but it doesn’t work although other commands are sent

Make sure that in the item settings (General > Hit) the Active Touch or Bounding Box events are
indicated. If you use Pass Through – the button will be "transparent", non-clickable. More>>

↑ Back

i2 Control, Supported OS

What OS does iRidium work on? What OS are planned to support in the future?

At the moment iRidium works on the following OS:

Apple iOS based devices - V6 and later: iPad (later than the 1st), iPhone (3Gs and later), iPod●

touch (4 generation and later)
Windows 7/8 based devices: PCs, monoblocks, tablet computers●

Android OS based devices – V2.3 and later: smartphones and tablet computers (your device●

should have a GPS module and an SD-card)
OS X based devices: OS X 10.5 Leopard and later (Mac Mini, iMac, MacPro, MacBook)●
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Support of other OS (Windows Phone 8, Windows RT, Linux, ...) is not planned in the nearest future.
Information about support of new systems will be published on the company information resources.

What Android devices has iRidium been tested on?

iRidium supports Android based smartphones and tablet PCs beginning with Android 2.3 and higher.
But we cannot guarantee its work on all devices as Android is an open OS and manufactures of
Android devices can make changes which are not compatible with iRidium work. The choice of
devices is made by you to your risk. We recommend to test how iRidium works on the selected panel
by launching a sample GUI on it.
Lab tests of iRidium for Android were made on such devices as HTC Sensation and HTC Incredible S
(UDP transport on HTC drain firmware does not work which causes inoperability of the "Search"
function and forced project update for this smartphone in Transfer. The update is possible after
restarting the application.), Sony Tablet S, Acer A500, Samsung Galaxy Tab, Acer Liquid and some
other. The testing cannot guarantee 100% work of your project in the similar Android device due to
the possible differences in the firmware and project functional.

Can notifications about the system events be received if iRidium is closed or minimized?

Notifications work only when the application is opened.

Can I update my design on the control panel via the Internet?

Yes, you can. In order to do that you need to set up the router and the client application. See more
information here.

How the projects can be saved Online?

Use your web site hosting, Google Disk or Amazon S3 to store your visualization interfaces. They can
be loaded in i2 Control V2.2 by clicking on the link.

Does iRidium work via 3G?

Yes, it does. iRidium can work with any way of connection to the Internet. The faster is the
connection, the more responsive is the interface.

How to download the project from i2 Control V2.2 back to my PC?

At the moment the download of projects from control panels to PC is not possible. Save initial copies
of your projects on secure carriers and on-line resources.

Can I upload the project on my iOS or Android device without a license?
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Yes, you can. But there won't be any communication with equipment: you will not be able to send
commands to controllers and receive feedback. The other functions (graphics, navigation, interface
scripts) will work.

How can I see the log of i2 Control V2.2 and Emulator?

You can open the log window in Windows by pressing F4. iOS/Android/OS X devices have the tool of
remote debugging (the log can be saved on your PC). Read more here.

Will iRidium work after updating the firmware on iPhone/iPad/iPod touch?

Do not update the firmware of your device until making sure that iRidium client has been updated
accordingly. Changes in iOS can lead to problems with software work. If you have problems with the
control interface after updating the firmware, it is recommended to reinstall iRidium on your iOS
device and upload the design on the device again.

i2 Control V2.2 doesn't close on my PC (remains in the list of the task manager)

This problem might be connected with incorrect work of DirextX on your PC. Open the application
settings (F8 > password 2007), and change DX9 to OGL in the Render tab. Save the changes.

↑ Back

iRidium Transfer

The "Search" function for panels doesn't work.

The search system in Transfer can have problems because of different reasons. Most likely it is
because of the anti-virus or problems with network settings (Transfer and your control panel are in
different IP subnetworks). See more information here.

Upload of my project on the control panel doesn't work.

Sometimes, even if the Search function in Transfer works, you can face problems with uploading
projects on your panel: the upload doesn't start or the project is not updated. See information about
how to solve these problems here.

How many designs can be uploaded on one control device?

The Multi-design function in Transfer enables upload of several designs on one device at a time (the
number of designs is limited only by the available memory of the panel). By default the Multi-design
function is not activated and only one design can be uploaded on the device. It substitutes the
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previous one.

Is it possible to update the project via the Internet? Is DynDNS supported?

iRidium supports project update on the control panel via the Internet. See more information here.

"Unknown file format" when adding projects in Transfer

It is possible that the Transfer version is older than the project version. First of all, update the
iRidium components on your PC and check that there are no reserved characters used in the path to
the file. If it doesn't help, send your project to iRidium Support Team so they could help you to solve
the problem.

Every time I start Transfer I receive a new HWID of my PC. What should I do?

HWID is a unique device identifier. It should not change. Otherwise your license will not work. If you
have such a problem there can be several explanations:
a) you work on a virtual machine (Windows Emulator). Switch to the regular Windows based PC.
b) you have hard disk RAID-array used on your PC. Deactivate it.

I cannot add my license to Transfer. I receive the message "Wrong licence".

This message informs that the license file is corrupted. Try to download it from your My Account
section again but through another browser.

↑ Back

iRidium Script

See iRidium Script API and iRidium DDK
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iRidium Gate

Is iRidium Gate required to use? Will there be connection with the equipment without this
application?

You don't have to use the iRidium Gate application. The client communicates with equipment
directly. But there are cases when Gate improves control capabilities, makes work via the Internet
possible, enables connection of several clients to the controller. See more information about how
iRidium Gate works with different systems.

Does iRidium Gate work on Linux?
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No, it doesn't. In V2.1 the Gate application works on Windows only.

↑ Back

If you haven’t found the answer to your question here, please see main Wiki
sections.
If you cannot find the required information there, contact us at
support@iridiummobile.ru</a> and we will reply to you promptly.
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